Bug 803358 (CVE-2012-1174) - CVE-2012-1174 systemd (systemd-logind): TOCTOU race condition by removing user session
Summary: CVE-2012-1174 systemd (systemd-logind): TOCTOU race condition by removing use...
Keywords:
Status: NEW
Alias: CVE-2012-1174
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20120316,repor...
Depends On: 804118
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-14 14:27 UTC by Jan Lieskovsky
Modified: 2019-06-08 19:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
Proposed patch from Michal Schmidt, original issue reporter (1.01 KB, patch)
2012-03-14 14:33 UTC, Jan Lieskovsky
no flags Details | Diff

Description Jan Lieskovsky 2012-03-14 14:27:45 UTC
A TOCTOU race condition was found in the way the systemd-logind login manager of the systemd, a system and service manager for Linux, performed removal of particular records related with user session upon user logout. A local attacker could use this flaw to conduct symbolic link attacks, potentially leading to removal of arbitrary system file.

Comment 2 Jan Lieskovsky 2012-03-14 14:33:11 UTC
Created attachment 570001 [details]
Proposed patch from Michal Schmidt, original issue reporter

Comment 3 Jan Lieskovsky 2012-03-14 14:33:54 UTC
This issue affects the versions of the systemd package, as shipped with Fedora release of 15 and 16.

Comment 4 Jan Lieskovsky 2012-03-14 14:34:24 UTC
The preliminary embargo date for this issue has been set up to this Friday, 2012-03-16.

Comment 5 Jan Lieskovsky 2012-03-14 14:37:52 UTC
The CVE identifier of CVE-2012-1174 has been assigned to this issue.

Comment 7 Michal Schmidt 2012-03-14 15:08:46 UTC
(In reply to comment #3)
> This issue affects the versions of the systemd package, as shipped with Fedora
> release of 15 and 16.

Just a note: The above sentence is correct, even though F15 does not contain the systemd-logind daemon. In F15 the vulnerable code is called from the PAM module instead. I haven't tried exploiting it on F15, but I see nothing that would make it impossible.

Comment 10 Jan Lieskovsky 2012-03-16 15:11:33 UTC
Created systemd tracking bugs for this issue

Affects: fedora-all [bug 804118]

Comment 12 Fedora Update System 2012-03-26 03:54:45 UTC
systemd-26-18.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-03-26 03:58:25 UTC
systemd-37-17.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-03-26 17:55:09 UTC
systemd-26-18.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2012-03-26 18:00:15 UTC
systemd-37-17.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2012-04-25 05:02:58 UTC
systemd-44-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.