Bug 1179870 (CVE-2012-6684) - CVE-2012-6684 rubygem-RedCloth: XSS vulnerability
Summary: CVE-2012-6684 rubygem-RedCloth: XSS vulnerability
Keywords:
Status: NEW
Alias: CVE-2012-6684
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1179874 1179872 1179873
Blocks: 1179871
TreeView+ depends on / blocked
 
Reported: 2015-01-07 17:16 UTC by Vincent Danen
Modified: 2019-09-29 13:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Vincent Danen 2015-01-07 17:16:49 UTC
A Cross-Site Scripting (XSS) vulnerability was reported [1],[2] in the RedCloth rubygem.  This has not been fixed upstream, but Redmine uses a copy of RedCloth and has a patch [3].

[1] https://gist.github.com/co3k/75b3cb416c342aa1414c
[2] http://co3k.org/blog/redcloth-unfixed-xss-en
[3] http://www.redmine.org/projects/redmine/repository/revisions/2212/diff/trunk/lib/redcloth3.rb

Comment 1 Vincent Danen 2015-01-07 17:20:44 UTC
Created rubygem-RedCloth tracking bugs for this issue:

Affects: fedora-all [bug 1179872]
Affects: epel-5 [bug 1179873]
Affects: epel-6 [bug 1179874]


Note You need to log in before you can comment on or make changes to this bug.