Bug 949753 (CVE-2013-2777) - CVE-2013-2777 sudo: bypass of tty_tickets constraints
Summary: CVE-2013-2777 sudo: bypass of tty_tickets constraints
Alias: CVE-2013-2777
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Depends On: 1015355
Blocks: 916366 974906
TreeView+ depends on / blocked
Reported: 2013-04-08 22:42 UTC by Vincent Danen
Modified: 2019-09-29 13:02 UTC (History)
2 users (show)

Fixed In Version: sudo 1.8.6p6, sudo 1.7.10p5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2013-11-22 05:36:55 UTC

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:1701 0 normal SHIPPED_LIVE Low: sudo security, bug fix and enhancement update 2013-11-20 21:52:06 UTC

Description Vincent Danen 2013-04-08 22:42:42 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2013-2777 to
the following vulnerability:

Name: CVE-2013-2777
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-2777
Assigned: 20130408
Reference: http://www.openwall.com/lists/oss-security/2013/02/27/31
Reference: https://bugzilla.redhat.com/show_bug.cgi?id=916365
Reference: http://www.sudo.ws/repos/sudo/rev/2f3225a2a4a4
Reference: http://www.sudo.ws/repos/sudo/rev/bfa23f089bba
Reference: http://www.sudo.ws/sudo/alerts/tty_tickets.html
Reference: http://www.securityfocus.com/bid/58207

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets
option is enabled, does not properly validate the controlling terminal
device, which allows local users with sudo permissions to hijack the
authorization of another terminal via vectors related to a session
without a controlling terminal device and connecting to a standard
input, output, and error file descriptors of another terminal.  NOTE:
this is one of three closely-related vulnerabilities that were
originally assigned CVE-2013-1776, but they have been SPLIT because of
different affected versions.

Comment 2 Huzaifa S. Sidhpurwala 2013-09-26 09:53:39 UTC
Looking at the upstream commits, it seems that this flaw exists because of incomplete/insufficient fix applied for the CVE-2013-1776 flaw.

Since the patch for CVE-2013-1776 was not backported to Red Hat Enterprise Linux 5, this flaw does not affect it

Comment 5 Tomas Hoger 2013-10-09 21:11:47 UTC
(In reply to Huzaifa S. Sidhpurwala from comment #2)
> Looking at the upstream commits, it seems that this flaw exists because of
> incomplete/insufficient fix applied for the CVE-2013-1776 flaw.

Hence this CVE affects versions starting with 1.7.10 and 1.8.5 and is corrected in versions 1.7.10p5 and 1.8.6p6.

Comment 6 errata-xmlrpc 2013-11-21 23:12:53 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:1701 https://rhn.redhat.com/errata/RHSA-2013-1701.html

Note You need to log in before you can comment on or make changes to this bug.