Bug 1076335 (CVE-2014-0135) - CVE-2014-0135 rubygem-kafo: temporary file creation vulnerability when creating /tmp/default_values.yaml
Summary: CVE-2014-0135 rubygem-kafo: temporary file creation vulnerability when creati...
Status: CLOSED CURRENTRELEASE
Alias: CVE-2014-0135
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150206,repor...
Keywords: Security
Depends On: 1081730 1081731
Blocks: 1085960
TreeView+ depends on / blocked
 
Reported: 2014-03-14 06:10 UTC by Trevor Jay
Modified: 2019-06-08 19:57 UTC (History)
18 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-01-21 21:47:07 UTC


Attachments (Terms of Use)

Description Trevor Jay 2014-03-14 06:10:41 UTC
Dominic Cleal of Red Hat reports:

The kafo_configure puppet module creates /tmp/default_values.yaml world readable and without checking for it's existance. This creates a race-condition that would allow a local attacker to control the contents of the file which stores default values for all parameters (such as auto-generated passwords). 

References:
http://projects.theforeman.org/issues/4648


Note You need to log in before you can comment on or make changes to this bug.