Bug 1647431 (CVE-2014-10077) - CVE-2014-10077 rubygem-i18n: denial of service in Hash#slice in lib/i18n/core_ext/hash.rb
Summary: CVE-2014-10077 rubygem-i18n: denial of service in Hash#slice in lib/i18n/core...
Keywords:
Status: NEW
Alias: CVE-2014-10077
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1647433 1647432 1648914 1652018 1652019
Blocks: 1647434
TreeView+ depends on / blocked
 
Reported: 2018-11-07 13:18 UTC by Laura Pardo
Modified: 2019-09-29 15:02 UTC (History)
26 users (show)

Fixed In Version: rubygem-i18n 0.8.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Laura Pardo 2018-11-07 13:18:06 UTC
A flaw was found in the i18n gem before 0.8.0 for Ruby. The Hash#slice in lib/i18n/core_ext/hash.rb allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash. 


References:
https://github.com/rubysec/ruby-advisory-db/pull/182/files 
https://github.com/svenfuchs/i18n/pull/289 
https://github.com/svenfuchs/i18n/releases/tag/v0.8.0

Comment 1 Laura Pardo 2018-11-07 13:18:48 UTC
Created rubygem-i18n tracking bugs for this issue:

Affects: epel-7 [bug 1647433]
Affects: fedora-all [bug 1647432]

Comment 5 Sam Fowler 2018-12-07 04:00:48 UTC
This issue affects the versions of rubygem-i18n shipped in the logging-fluentd and ose-logging-fluentd containers in OpenShift Container Platform before version 3.6. Red Hat Product Security has rated this issue as having a security impact of Low and is not currently planed to be addressed in future updates. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

Comment 8 Cedric Buissart 🐶 2019-01-08 13:38:24 UTC
Statement:

Red Hat Satellite 6.2 is now in Maintenance support 2 phase of the support and maintenance life cycle. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Satellite Product Life Cycle: https://access.redhat.com/support/policy/updates/satellite
Red Hat Satellite 6.3 and 6.4 don't include vulnerable package  tfm-rubygem-i18n, hence are not affected by this flaw.

Subscription Asset Manager is now in a reduced support phase receiving only Critical impact security fixes. This issue has been rated as having a security impact of Low, and is not currently planned to be addressed in future updates.


Note You need to log in before you can comment on or make changes to this bug.