Bug 1174492 (CVE-2014-1569) - CVE-2014-1569 nss: QuickDER decoder length issue
Summary: CVE-2014-1569 nss: QuickDER decoder length issue
Alias: CVE-2014-1569
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Depends On: 1174493
Blocks: 1174495
TreeView+ depends on / blocked
Reported: 2014-12-15 23:34 UTC by Murray McAllister
Modified: 2021-02-17 05:53 UTC (History)
8 users (show)

Fixed In Version: nss 3.17.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-07-25 12:51:20 UTC

Attachments (Terms of Use)

Description Murray McAllister 2014-12-15 23:34:27 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2014-1569 to
the following vulnerability:

Name: CVE-2014-1569
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1569
Assigned: 20140116
Reference: http://www.intelsecurity.com/resources/wp-berserk-analysis-part-1.pdf
Reference: https://www.imperialviolet.org/2014/09/26/pkcs1.html
Reference: https://www.reddit.com/r/netsec/comments/2hd1m8/rsa_signature_forgery_in_nss/cksnr02
Reference: https://bugzilla.mozilla.org/show_bug.cgi?id=1064670
Reference: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.17.3_release_notes

The definite_length_decoder function in lib/util/quickder.c in Mozilla
Network Security Services (NSS) before and 3.17.x before
3.17.3 does not ensure that the DER encoding of an ASN.1 length is
properly formed, which allows remote attackers to conduct
data-smuggling attacks by using a long byte sequence for an encoding,
as demonstrated by the SEC_QuickDERDecodeItem function's improper
handling of an arbitrary-length encoding of 0x00.

We believe the CVE-2014-1568 issue is required to trigger this bug, and that issue has already been resolved in Red Hat Enterprise Linux:


Comment 1 Murray McAllister 2014-12-15 23:34:57 UTC
Created nss tracking bugs for this issue:

Affects: fedora-all [bug 1174493]

Comment 5 David Sirrine 2015-05-12 20:01:09 UTC
As RHEL seems to have rebased to nss 3.18.0, are they still vulnerable to this CVE? Given the text of the advisory from Mozilla, it appears as though it only affects 3.17.x before 3.17.3. Thanks in advance.

Comment 6 Fabio Olive Leite 2015-05-12 20:13:14 UTC
Changing needinfo from s-r-t@ to Huzaifa. He should be able to answer that.

Comment 7 Simon Atwater 2015-06-29 20:03:58 UTC
I am also interested in the answer to David Sirrine's question. Has Huzaifa weighed in?

Comment 8 Huzaifa S. Sidhpurwala 2015-07-25 12:51:20 UTC
This issue was fixed in upstream nss-3.17.3 as described in the release notes at:


Consequently nss packages shipped with Red Hat Enterprise Linux 5, 6 and 7 were rebased to 3.18.0 via the following advisories.

Red Hat Enterprise Linux 5:

Red Hat Enterprise Linux 6:

Red Hat Enterprise Linux 7:

This particular rebase fixed this security flaw.

Comment 9 Huzaifa S. Sidhpurwala 2015-07-25 12:55:06 UTC


Note You need to log in before you can comment on or make changes to this bug.