Bug 1067713 (CVE-2014-1879) - CVE-2014-1879 phpMyAdmin: XSS in import.php
Summary: CVE-2014-1879 phpMyAdmin: XSS in import.php
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2014-1879
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20140205,repor...
Depends On: 1067714 1067715 1067716 1067717
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-20 22:46 UTC by Vincent Danen
Modified: 2019-06-08 19:55 UTC (History)
7 users (show)

Fixed In Version: phpMyAdmin 4.1.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 17:36:51 UTC


Attachments (Terms of Use)

Description Vincent Danen 2014-02-20 22:46:32 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2014-1879 to
the following vulnerability:

Name: CVE-2014-1879
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1879
Assigned: 20140207
Reference: http://www.phpmyadmin.net/home_page/security/PMASA-2014-1.php
Reference: https://github.com/phpmyadmin/phpmyadmin/commit/968d5d5f486820bfa30af046f063b9f23304e14a

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin
before 4.1.7 allows remote authenticated users to inject arbitrary web
script or HTML via a crafted filename in an import action.

Comment 2 Vincent Danen 2014-02-20 22:49:01 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1067714]
Affects: epel-6 [bug 1067715]

Comment 3 Vincent Danen 2014-02-20 22:49:06 UTC
Created phpMyAdmin3 tracking bugs for this issue:

Affects: epel-5 [bug 1067716]

Comment 4 Fedora Update System 2014-07-30 07:01:04 UTC
phpMyAdmin-4.2.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-07-30 07:02:35 UTC
phpMyAdmin-4.2.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-08-07 11:46:11 UTC
phpMyAdmin-4.0.10.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-10-09 19:55:11 UTC
phpMyAdmin4-4.0.10.3-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.