Bug 1151381 (CVE-2014-3190, CVE-2014-3191, CVE-2014-3193, CVE-2014-3199) - CVE-2014-3190 CVE-2014-3191 CVE-2014-3193 CVE-2014-3199 chromium: multiple security fixes in Chrome 38.0.2125.101
Summary: CVE-2014-3190 CVE-2014-3191 CVE-2014-3193 CVE-2014-3199 chromium: multiple se...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2014-3190, CVE-2014-3191, CVE-2014-3193, CVE-2014-3199
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1151335 1151338
Blocks: 1151371
TreeView+ depends on / blocked
 
Reported: 2014-10-10 09:24 UTC by Tomas Hoger
Modified: 2019-09-29 13:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 08:46:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2014:1626 normal SHIPPED_LIVE Critical: chromium-browser security update 2014-10-14 11:22:06 UTC

Description Tomas Hoger 2014-10-10 09:24:01 UTC
Chrome version 38.0.2125.101 fixes multiple security flaws:

CVE-2014-3190

Use-after-free vulnerability in the Event::currentTarget function in core/events/Event.cpp in Blink, as used in Google Chrome before 38.0.2125.101, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted JavaScript code that accesses the path property of an Event object. 

https://crbug.com/400476
https://src.chromium.org/viewvc/blink?revision=181234&view=revision

CVE-2014-3191

Use-after-free vulnerability in Blink, as used in Google Chrome before 38.0.2125.101, allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted JavaScript code that triggers a widget-position update that improperly interacts with the render tree, related to the FrameView::updateLayoutAndStyleForPainting function in core/frame/FrameView.cpp and the RenderLayerScrollableArea::setScrollOffset function in core/rendering/RenderLayerScrollableArea.cpp.

https://crbug.com/402407
https://src.chromium.org/viewvc/blink?revision=180681&view=revision

CVE-2014-3193

The SessionService::GetLastSession function in browser/sessions/session_service.cc in Google Chrome before 38.0.2125.101 allows remote attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact via vectors that leverage "type confusion" for callback processing. 

https://crbug.com/399655
https://codereview.chromium.org/500143002/

CVE-2014-3199

The wrap function in bindings/core/v8/custom/V8EventCustom.cpp in the V8 bindings in Blink, as used in Google Chrome before 38.0.2125.101, has an erroneous fallback outcome for wrapper-selection failures, which allows remote attackers to cause a denial of service via vectors that trigger stopping a worker process that had been handling an Event object. 

https://crbug.com/395411
https://src.chromium.org/viewvc/blink?revision=179340&view=revision

External References:

http://googlechromereleases.blogspot.com/2014/10/stable-channel-update.html

Comment 2 errata-xmlrpc 2014-10-14 08:35:07 UTC
This issue has been addressed in the following products:

  Supplementary for Red Hat Enterprise Linux 6

Via RHSA-2014:1626 https://rhn.redhat.com/errata/RHSA-2014-1626.html


Note You need to log in before you can comment on or make changes to this bug.