Bug 1828684 (CVE-2014-4678) - CVE-2014-4678 ansible: safe_eval function does not properly restrict the code subset leads to arbitrary code execution via crafted instructions
Summary: CVE-2014-4678 ansible: safe_eval function does not properly restrict the code...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2014-4678
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1838255
TreeView+ depends on / blocked
 
Reported: 2020-04-28 07:01 UTC by Dhananjay Arunesh
Modified: 2021-02-16 13:59 UTC (History)
39 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in ansible. The safe_eval function does not properly restrict the code subset which allows remote attackers to execute arbitrary code via crafted instructions. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2020-04-28 10:31:52 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2020-04-28 07:01:24 UTC
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.

Reference:
https://github.com/ansible/ansible/commit/5429b85b9f6c2e640074176f36ff05fd5e4d1916
https://groups.google.com/forum/message/raw?msg=ansible-announce/ieV1vZvcTXU/5Q93ThkY9rIJ
https://www.openwall.com/lists/oss-security/2014/06/26/30
https://www.openwall.com/lists/oss-security/2014/07/02/2

Comment 1 Product Security DevOps Team 2020-04-28 10:31:52 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2014-4678

Comment 2 Yadnyawalk Tale 2020-05-22 16:08:27 UTC
I think resolution is quite clear here, in any case, Red Hat CloudForms 5.10 (4.7) and 5.11 (5.0) do not ship `ansible` package, it is provided by the official Ansible repository.

Comment 3 Hardik Vyas 2020-05-26 05:15:24 UTC
Statement:

Red Hat Ceph Storage and Red Hat Gluster Storage shipped ansible versions 2.4.1 and 2.3.2 respectively, which are not affected by this vulnerability.


Note You need to log in before you can comment on or make changes to this bug.