Bug 1170597 (CVE-2014-9218) - CVE-2014-9218 phpMyAdmin: Denial of Service with long passwords
Summary: CVE-2014-9218 phpMyAdmin: Denial of Service with long passwords
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2014-9218
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1170598 1170599 1170600 1170601 1181877
Blocks: 1170603
TreeView+ depends on / blocked
 
Reported: 2014-12-04 12:37 UTC by Martin Prpič
Modified: 2019-09-29 13:25 UTC (History)
13 users (show)

Fixed In Version: phpMyAdmin 4.0.10.7, phpMyAdmin 4.1.14.8, phpMyAdmin 4.2.13.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-14 01:00:07 UTC


Attachments (Terms of Use)

Description Martin Prpič 2014-12-04 12:37:28 UTC
It was found that long passwords could cause a denial of service in phpMyAdmin.

Upstream patch:

https://github.com/phpmyadmin/phpmyadmin/commit/1ac863c7573d12012374d5d41e5c7dc5505ea6e1

Upstream advisory:

http://www.phpmyadmin.net/home_page/security/PMASA-2014-17.php

Comment 1 Martin Prpič 2014-12-04 12:39:35 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1170598]
Affects: epel-6 [bug 1170600]
Affects: epel-7 [bug 1170601]

Comment 2 Martin Prpič 2014-12-04 12:39:37 UTC
Created phpMyAdmin4 tracking bugs for this issue:

Affects: epel-5 [bug 1170599]

Comment 3 Fedora Update System 2014-12-12 04:10:23 UTC
phpMyAdmin-4.2.13.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2014-12-12 04:20:58 UTC
phpMyAdmin-4.2.13.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-12-14 22:06:33 UTC
phpMyAdmin-4.0.10.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-12-14 22:07:17 UTC
phpMyAdmin-4.2.13.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-12-15 04:28:25 UTC
phpMyAdmin-4.2.13.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-02-27 22:40:33 UTC
phpMyAdmin4-4.0.10.7-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.