Bug 1187148 (CVE-2015-0268) - CVE-2015-0268 xen: GICD_SGIR is not properly emulated on ARM architecture (XSA-117)
Summary: CVE-2015-0268 xen: GICD_SGIR is not properly emulated on ARM architecture (XS...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2015-0268
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1194675
Blocks: 1190624
TreeView+ depends on / blocked
 
Reported: 2015-01-29 12:25 UTC by Vasyl Kaigorodov
Modified: 2023-05-12 07:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-20 14:01:21 UTC
Embargoed:


Attachments (Terms of Use)

Description Vasyl Kaigorodov 2015-01-29 12:25:12 UTC
ISSUE DESCRIPTION
=================

When decoding a guest write to a specific register in the virtual
interrupt controller Xen would treat an invalid value as a critical
error and crash the host.

IMPACT
======

By writing an invalid value to the GICD.SGIR register a guest can
crash the host, resulting in a Denial of Service attack.

VULNERABLE SYSTEMS
==================

Xen 4.5 and later systems running on ARM hardware with version 2 of
the generic interrupt controller are vulnerable.

Systems running on ARM hardware with version 3 of the generic
interrupt controller are not vulnerable.

x86 systems are not affected.

Statement:

This issue did not affect the versions of xen as shipped with Red Hat Enterprise Linux 5.

Acknowledgements:

Red Hat would like to thank the Xen project for reporting this issue.

Comment 1 Kurt Seifried 2015-02-12 22:34:58 UTC
This is now public:

http://seclists.org/oss-sec/2015/q1/534

Comment 2 Petr Matousek 2015-02-20 14:01:05 UTC
Created xen tracking bugs for this issue:

Affects: fedora-all [bug 1194675]


Note You need to log in before you can comment on or make changes to this bug.