Bug 1194730 (CVE-2015-0273) - CVE-2015-0273 php: use after free vulnerability in unserialize() with DateTimeZone
Summary: CVE-2015-0273 php: use after free vulnerability in unserialize() with DateTim...
Status: CLOSED ERRATA
Alias: CVE-2015-0273
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150219,repor...
Keywords: Security
Depends On: 1204762 1204763 1204765 1204766 1209880 1209884 1209887
Blocks: 1194715 1210213
TreeView+ depends on / blocked
 
Reported: 2015-02-20 16:03 UTC by Vasyl Kaigorodov
Modified: 2019-07-11 08:41 UTC (History)
26 users (show)

(edit)
A use-after-free flaw was found in the unserialize() function of PHP's DateTimeZone implementation. A malicious script author could possibly use this flaw to disclose certain portions of server memory.
Clone Of:
(edit)
Last Closed: 2015-07-09 21:45:09 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1053 normal SHIPPED_LIVE Moderate: php55 security and bug fix update 2015-06-04 12:06:06 UTC
Red Hat Product Errata RHSA-2015:1066 normal SHIPPED_LIVE Important: php54 security and bug fix update 2015-06-05 15:42:20 UTC
Red Hat Product Errata RHSA-2015:1135 normal SHIPPED_LIVE Important: php security and bug fix update 2015-06-23 12:11:40 UTC
Red Hat Product Errata RHSA-2015:1218 normal SHIPPED_LIVE Moderate: php security update 2015-07-09 21:01:41 UTC

Description Vasyl Kaigorodov 2015-02-20 16:03:55 UTC
Use after free vulnerability was reported in PHP DateTimeZone [1].
Upstream patches that fix this:
http://git.php.net/?p=php-src.git;a=commit;h=c377f1a715476934133f3254d1e0d4bf3743e2d2
http://git.php.net/?p=php-src.git;a=commit;h=71335e6ebabc1b12c057d8017fd811892ecdfd24

[1]: https://bugs.php.net/bug.php?id=68942

Comment 1 Vasyl Kaigorodov 2015-03-02 10:07:06 UTC
Statement:

This issue did not affect the versions of php as shipped with Red Hat Enterprise Linux 5 as they did not include the vulnerable code.

Comment 2 Pasi Koistinen 2015-03-05 14:05:09 UTC
Could you please confirm that Red Hat Enterprise Linux 6 is not affected?

Comment 3 Angelo Alvarez 2015-03-07 02:18:06 UTC
Can someone at Red Hat take the initiative and update the CVE page??
https://access.redhat.com/security/cve/CVE-2015-0273
Customers shouldn't have to crawl through bugzilla to find out if our platforms are vulnerable.

Also the statement should include PHP and PHP53 applicabililty of the CVE.

Comment 4 Francisco Alonso 2015-03-10 13:46:26 UTC
Fixed upstream in PHP 5.6.6, 5.5.22, and 5.4.38:

http://php.net/ChangeLog-5.php#5.6.6
http://php.net/ChangeLog-5.php#5.5.22
http://php.net/ChangeLog-5.php#5.4.38

Comment 16 Carl Riches 2015-05-27 16:50:59 UTC
It is not clear from the CVE notice (https://access.redhat.com/security/cve/CVE-2015-0273) nor from this Bugzilla entry whether or not RHEL 7.1 or RHEL 6.6 are vulnerable.

RHEL 6.6:  php-5.3.3
RHEL 7.1:  php-5.4.16

Please clarify.  Thanks!

Comment 17 errata-xmlrpc 2015-06-04 08:03:57 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 6
  Red Hat Software Collections for Red Hat Enterprise Linux 6.6 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 6.5 EUS

Via RHSA-2015:1066 https://rhn.redhat.com/errata/RHSA-2015-1066.html

Comment 18 errata-xmlrpc 2015-06-04 08:07:19 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 6
  Red Hat Software Collections for Red Hat Enterprise Linux 6.6 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 6.5 EUS

Via RHSA-2015:1053 https://rhn.redhat.com/errata/RHSA-2015-1053.html

Comment 19 errata-xmlrpc 2015-06-23 08:12:08 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:1135 https://rhn.redhat.com/errata/RHSA-2015-1135.html

Comment 20 errata-xmlrpc 2015-07-09 17:07:01 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2015:1218 https://rhn.redhat.com/errata/RHSA-2015-1218.html


Note You need to log in before you can comment on or make changes to this bug.