Bug 1220616 (CVE-2015-0971) - CVE-2015-0971 suricata: SSL/TLS DER parser bug
Summary: CVE-2015-0971 suricata: SSL/TLS DER parser bug
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2015-0971
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1220618
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-12 02:43 UTC by Fabio Olive Leite
Modified: 2019-09-29 13:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-10 20:32:52 UTC


Attachments (Terms of Use)

Description Fabio Olive Leite 2015-05-12 02:43:37 UTC
It was reported that Suricata 2.0.8 fixes a bug in its SSL/TLS parser
for DER-encoded certificates. An attacker is able to crash Suricata
remotely.

References:
http://suricata-ids.org/2015/05/06/suricata-2-0-8-available/

Comment 1 Fabio Olive Leite 2015-05-12 02:47:58 UTC
Created suricata tracking bugs for this issue:

Affects: fedora-all [bug 1220618]

Comment 2 Steve Grubb 2015-05-12 13:06:09 UTC
This was pushed into testing 5 days ago. IMHO, this bz should not have been opened. It can use some karma if it needs to get out faster.


Note You need to log in before you can comment on or make changes to this bug.