Bug 1234415 (CVE-2015-4651) - CVE-2015-4651 wireshark: WCCP dissector crash (wnpa-sec-2015-19)
Summary: CVE-2015-4651 wireshark: WCCP dissector crash (wnpa-sec-2015-19)
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2015-4651
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1234417
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-22 13:53 UTC by Vasyl Kaigorodov
Modified: 2019-09-29 13:34 UTC (History)
6 users (show)

Fixed In Version: Wireshark 1.12.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-09 03:44:23 UTC


Attachments (Terms of Use)

Description Vasyl Kaigorodov 2015-06-22 13:53:13 UTC
It was reported that it may be possible to make Wireshark crash by injecting a malformed WCCP packet onto the wire or by convincing someone to read a malformed packet trace file.
Upstream bug: https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11153
Upstream commit: https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=524ed1df6e6126cd63ba419ccb82c83636d77ee4

External References:

https://www.wireshark.org/security/wnpa-sec-2015-19.html

Statement:

This issue did not affect the versions of wireshark as shipped with Red Hat Enterprise Linux 5, 6 and 7.

Comment 1 Vasyl Kaigorodov 2015-06-22 13:57:38 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1234417]


Note You need to log in before you can comment on or make changes to this bug.