Bug 1255896 (CVE-2015-5225) - CVE-2015-5225 Qemu: ui: vnc: heap memory corruption in vnc_refresh_server_surface
Summary: CVE-2015-5225 Qemu: ui: vnc: heap memory corruption in vnc_refresh_server_sur...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2015-5225
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1255897 1255898 1255899 1259190 1259191 1259192
Blocks: 1253307
TreeView+ depends on / blocked
 
Reported: 2015-08-21 19:57 UTC by Prasad J Pandit
Modified: 2019-09-29 13:36 UTC (History)
51 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A heap-based buffer overflow issue was found in the QEMU emulator's VNC display driver. It could occur while refreshing the VNC server's display surface using the vnc_refresh_server_surface() routine. A privileged guest user could use this flaw to corrupt the heap memory and crash the QEMU process instance, or to potentially use it to execute arbitrary code on the host.
Clone Of:
Environment:
Last Closed: 2015-10-15 20:03:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1772 normal SHIPPED_LIVE Important: qemu-kvm-rhev security update 2015-09-14 08:22:46 UTC
Red Hat Product Errata RHSA-2015:1837 normal SHIPPED_LIVE Important: qemu-kvm-rhev security update 2015-09-24 18:21:01 UTC

Description Prasad J Pandit 2015-08-21 19:57:43 UTC
Qemu emulator built with the VNC display driver support is vulnerable to a
buffer overflow flaw leading to heap memory corruption. It could occur while
refreshing the server display surface via routine vnc_refresh_server_surface().

A privileged guest user could use this flaw to corrupt the heap memory and crash the Qemu process instance OR potentially use it to execute arbitrary code on the host.

Upstream fix:
-------------
  -> https://lists.gnu.org/archive/html/qemu-devel/2015-08/msg02495.html

Issue introduced by:
--------------------
  -> http://git.qemu.org/?p=qemu.git;a=commit;h=bea60dd7679364493a0d7f5b

Comment 2 Prasad J Pandit 2015-08-21 20:01:24 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1255899]

Comment 3 Prasad J Pandit 2015-08-21 20:08:37 UTC
Statement: 

This issue does not affect the versions of kvm and xen packages as shipped with Red Hat Enterprise Linux 5.

This issue does not affect the versions of the qemu-kvm packages as shipped with Red Hat Enterprise Linux 6 and 7.

This issue does not affect the Red Hat Enterprise Linux 6 based versions of qemu-kvm-rhev packages as shipped with Red Hat Enterprise Virtualization 3.

This issue does affect the Red Hat Enterprise Linux 7 based versions of the qemu-kvm-rhev packages as shipped with Red Hat Enterprise Virtualization 3. Future updates for this release may address this flaw.

Comment 4 Prasad J Pandit 2015-08-21 20:23:36 UTC
Acknowledgements:

Red Hat would like to thank Mr Qinghao Tang from QIHU 360 Inc. and Mr Zuozhi from Alibaba Inc. for reporting this issue.

Comment 7 Fedora Update System 2015-09-04 03:23:03 UTC
qemu-2.4.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 errata-xmlrpc 2015-09-14 04:22:58 UTC
This issue has been addressed in the following products:

  OpenStack 5 for RHEL 7
  OpenStack 6 for RHEL 7
  OpenStack 7 For RHEL 7

Via RHSA-2015:1772 https://rhn.redhat.com/errata/RHSA-2015-1772.html

Comment 12 Fedora Update System 2015-09-18 20:51:08 UTC
qemu-2.3.1-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 errata-xmlrpc 2015-09-24 14:22:17 UTC
This issue has been addressed in the following products:

  RHEV-H and Agents for RHEL-7

Via RHSA-2015:1837 https://rhn.redhat.com/errata/RHSA-2015-1837.html

Comment 14 Fedora Update System 2015-10-09 11:21:13 UTC
qemu-2.1.3-11.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.