Bug 1261836 (CVE-2015-7673) - CVE-2015-7673 gdk-pixbuf: Heap overflow and DoS vulnerability when scaling a TGA file
Summary: CVE-2015-7673 gdk-pixbuf: Heap overflow and DoS vulnerability when scaling a ...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2015-7673
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1261849
TreeView+ depends on / blocked
 
Reported: 2015-09-10 09:44 UTC by Adam Mariš
Modified: 2021-02-17 04:56 UTC (History)
4 users (show)

Fixed In Version: gdk-pixbuf 2.32.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-23 12:57:30 UTC


Attachments (Terms of Use)

Description Adam Mariš 2015-09-10 09:44:29 UTC
It was reported that heap overflow and DoS in gdk-pixbuf implementation occurs triggered by scaling TGA file. This library is used also by Firefox and Chromium, making them vulnerable.

Comment 13 Adam Mariš 2015-10-02 08:12:12 UTC
CVE request:

http://seclists.org/oss-sec/2015/q4/1

Comment 14 Adam Mariš 2015-10-02 08:54:18 UTC
Acknowledgements:

Red Hat would like to thank Gustavo Grieco for reporting this issue.

Comment 15 Adam Mariš 2015-10-05 11:59:22 UTC
CVE assignment:

http://seclists.org/oss-sec/2015/q4/18

Comment 16 Stefan Cornelius 2015-10-23 12:55:05 UTC
The infinite loop in RHEL6 is annoying but shouldn't qualify as security issue.


Note You need to log in before you can comment on or make changes to this bug.