Bug 1285771 (CVE-2015-8027) - CVE-2015-8027 nodejs: unspecified denial of service vulnerability
Summary: CVE-2015-8027 nodejs: unspecified denial of service vulnerability
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2015-8027
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1285777
TreeView+ depends on / blocked
 
Reported: 2015-11-26 12:29 UTC by Martin Prpič
Modified: 2019-09-29 13:40 UTC (History)
37 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-22 22:04:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2105161 None None None 2015-12-22 15:22:51 UTC

Description Martin Prpič 2015-11-26 12:29:19 UTC
A denial of service flaw was reported in Node.js:

A bug exists in Node.js, all versions of v0.12.x through to v5.x inclusive, whereby an external attacker can cause a denial of service.

Full details of this vulnerability are embargoed until new releases are available on Wednesday the 2nd of December 2015, UTC (Tuesday the 1st of December US time).

The versions reported as vulnerable (0.12.x to 5.x) are not shipped in any Red Hat product. This bug will be updated with further information when more details are available.

External References:

https://nodejs.org/en/blog/vulnerability/cve-2015-8027_cve-2015-6764/

Comment 3 Kurt Seifried 2015-12-22 22:03:00 UTC
Statement:

This issue did not affect the versions of nodejs as shipped with Red Hat Enterprise Software Collections version 2, Red Hat OpenStack Platform and Red Hat Openshift Enterprise and Openshift Online as they do not include the vulnerable version of nodejs.


Note You need to log in before you can comment on or make changes to this bug.