Bug 1296075 (CVE-2015-8728) - CVE-2015-8728 wireshark: ANSI A & GSM A dissector crashes (wnpa-sec-2015-46)
Summary: CVE-2015-8728 wireshark: ANSI A & GSM A dissector crashes (wnpa-sec-2015-46)
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2015-8728
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1296097
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-06 10:06 UTC by Martin Prpič
Modified: 2021-02-17 04:33 UTC (History)
5 users (show)

Fixed In Version: wireshark 2.0.1, wireshark 1.12.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-06 10:28:50 UTC
Embargoed:


Attachments (Terms of Use)

Description Martin Prpič 2016-01-06 10:06:40 UTC
It was reported that Wireshark's ANSI A and GSM A dissectors could crash. It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

This flaw is fixed in the following Wireshark versions: 2.0.1, 1.12.9.

Upstream bug(s):

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11797

External References:

https://www.wireshark.org/security/wnpa-sec-2015-46

Comment 1 Martin Prpič 2016-01-06 10:26:28 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1296097]


Note You need to log in before you can comment on or make changes to this bug.