Bug 1203195 (CVE-2015-8856) - CVE-2015-8856 serve-index: persistant cross-site scripting flaw
Summary: CVE-2015-8856 serve-index: persistant cross-site scripting flaw
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2015-8856
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1203197 1203198 1203196
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 11:38 UTC by Martin Prpič
Modified: 2019-09-29 13:30 UTC (History)
2 users (show)

Fixed In Version: serve-index 1.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 02:40:00 UTC


Attachments (Terms of Use)

Description Martin Prpič 2015-03-18 11:38:26 UTC
When using serve-index middleware version < 1.6.3 file and directory names are not escaped in HTML output, remote users can influence file or directory names, and trigger a persistent XSS attack.

Upstream issue:

https://github.com/expressjs/serve-index/issues/28

External References:

https://nodesecurity.io/advisories/serve-static-xss

Comment 1 Martin Prpič 2015-03-18 11:39:00 UTC
Created nodejs-serve-index tracking bugs for this issue:

Affects: fedora-all [bug 1203196]
Affects: epel-6 [bug 1203197]
Affects: epel-7 [bug 1203198]

Comment 2 Andrej Nemec 2016-04-22 08:03:01 UTC
CVE assignment:

http://seclists.org/oss-sec/2016/q2/122

Comment 3 Product Security DevOps Team 2019-06-08 02:40:00 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.