Bug 1512102 (CVE-2016-10516) - CVE-2016-10516 python-werkzeug: Cross-site scripting in render_full function in debug/tbtools.py
Summary: CVE-2016-10516 python-werkzeug: Cross-site scripting in render_full function ...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2016-10516
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1512103 1512104
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 20:43 UTC by Pedro Sampaio
Modified: 2019-09-29 14:25 UTC (History)
32 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:31:03 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2017-11-10 20:43:42 UTC
Cross-site scripting (XSS) vulnerability in the render_full function in
debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as
used in Pallets Flask and other products) allows remote attackers to inject
arbitrary web script or HTML via a field that contains an exception
message.

Upstream patch:

https://github.com/pallets/werkzeug/pull/1001

References:

http://blog.neargle.com/2016/09/21/flask-src-review-get-a-xss-from-debuger/

Comment 1 Pedro Sampaio 2017-11-10 20:44:22 UTC
Created python-werkzeug tracking bugs for this issue:

Affects: epel-6 [bug 1512104]
Affects: fedora-all [bug 1512103]


Note You need to log in before you can comment on or make changes to this bug.