Bug 1551765 (CVE-2016-10714) - CVE-2016-10714 zsh: Off-by-one error results in undersized buffers
Summary: CVE-2016-10714 zsh: Off-by-one error results in undersized buffers
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2016-10714
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1551766
TreeView+ depends on / blocked
 
Reported: 2018-03-05 22:37 UTC by Laura Pardo
Modified: 2019-09-29 14:34 UTC (History)
6 users (show)

Fixed In Version: zsh 5.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-04 19:57:18 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-03-05 22:37:39 UTC
A flaw was found in zsh prior 5.3. There is an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.


Upstream Patch:
https://sourceforge.net/p/zsh/code/ci/a62e1640bcafbb82d86ea8d8ce057a83c4683d60


Note You need to log in before you can comment on or make changes to this bug.