Bug 1343085 (CVE-2016-5300) - CVE-2016-5300 expat: Little entropy used for hash initialization
Summary: CVE-2016-5300 expat: Little entropy used for hash initialization
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2016-5300
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1343089 1343086 1343087 1343088 1343090
Blocks: 1296104 1319739
TreeView+ depends on / blocked
 
Reported: 2016-06-06 13:14 UTC by Adam Mariš
Modified: 2019-09-29 13:50 UTC (History)
43 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-05 21:35:47 UTC


Attachments (Terms of Use)
Proposed upstream patch (4.42 KB, patch)
2016-06-06 13:19 UTC, Adam Mariš
no flags Details | Diff

Description Adam Mariš 2016-06-06 13:14:47 UTC
It was found that original fix for CVE-2012-0876 used too little entropy for the hash intilization.

CVE assignment:

http://seclists.org/oss-sec/2016/q2/473

Comment 1 Adam Mariš 2016-06-06 13:15:47 UTC
Created compat-expat1 tracking bugs for this issue:

Affects: fedora-all [bug 1343087]

Comment 2 Adam Mariš 2016-06-06 13:15:57 UTC
Created expat tracking bugs for this issue:

Affects: fedora-all [bug 1343086]

Comment 3 Adam Mariš 2016-06-06 13:16:05 UTC
Created mingw-expat tracking bugs for this issue:

Affects: fedora-all [bug 1343088]
Affects: epel-7 [bug 1343090]

Comment 4 Adam Mariš 2016-06-06 13:16:12 UTC
Created expat21 tracking bugs for this issue:

Affects: epel-all [bug 1343089]

Comment 5 Adam Mariš 2016-06-06 13:19:01 UTC
Created attachment 1165210 [details]
Proposed upstream patch


Note You need to log in before you can comment on or make changes to this bug.