Bug 1627754 (CVE-2016-7070) - CVE-2016-7070 Ansible Tower: PostgreSQL privilege escalation in Tower-deployed setups
Summary: CVE-2016-7070 Ansible Tower: PostgreSQL privilege escalation in Tower-deploye...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2016-7070
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1382047
TreeView+ depends on / blocked
 
Reported: 2018-09-11 11:57 UTC by Andrej Nemec
Modified: 2019-09-29 14:58 UTC (History)
2 users (show)

Fixed In Version: ansible_tower 3.0.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:37:44 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2018-09-11 11:57:14 UTC
A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An attacker could use this vulnerability to gain admin level access to the database. 

References:

https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html


Note You need to log in before you can comment on or make changes to this bug.