Bug 1396174 (CVE-2016-8647) - CVE-2016-8647 Ansible: in some circumstances the mysql_user module may fail to correctly change a password
Summary: CVE-2016-8647 Ansible: in some circumstances the mysql_user module may fail t...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-8647
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1396175 1396176 1447506 1470145
Blocks: 1396212 1396214 1396334 1456591
TreeView+ depends on / blocked
 
Reported: 2016-11-17 16:48 UTC by Kurt Seifried
Modified: 2019-09-29 14:00 UTC (History)
58 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
An input validation vulnerability was found in Ansible's mysql_user module which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.
Clone Of:
Environment:
Last Closed: 2019-06-08 03:02:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1685 normal SHIPPED_LIVE Important: ansible security, bug fix, and enhancement update 2017-07-06 11:23:28 UTC

Description Kurt Seifried 2016-11-17 16:48:48 UTC
It is reported that in Ansible, under some circumstances the mysql_user module may fail to correctly change a password. Thus an old password may still be active when it should have been changed.

External References:
https://github.com/ansible/ansible-modules-core/pull/5388

Comment 1 Kurt Seifried 2016-11-17 16:50:09 UTC
Created ansible tracking bugs for this issue:

Affects: fedora-all [bug 1396175]

Comment 2 Kurt Seifried 2016-11-17 16:50:43 UTC
Created ansible tracking bugs for this issue:

Affects: epel-all [bug 1396176]

Comment 4 Kevin Fenzi 2017-06-01 20:33:50 UTC
This was actually fixed in ansible-2.2.1.0 which was pushed a while back. ;(

Comment 5 Adam Mariš 2017-06-02 06:14:03 UTC
(In reply to Kevin Fenzi from comment #4)
> This was actually fixed in ansible-2.2.1.0 which was pushed a while back. ;(

Please, don't close the bug next time, we still have open trackers for this one. Thanks!

Comment 6 Kevin Fenzi 2017-06-02 16:21:15 UTC
Oops. Very sorry about that...

Comment 7 errata-xmlrpc 2017-07-06 07:28:26 UTC
This issue has been addressed in the following products:

  RHEV Engine version 4.1

Via RHSA-2017:1685 https://access.redhat.com/errata/RHSA-2017:1685


Note You need to log in before you can comment on or make changes to this bug.