Bug 1415996 (CVE-2017-1000014) - CVE-2017-1000014 phpMyAdmin: DOS vulnerabiltiy in table editing
Summary: CVE-2017-1000014 phpMyAdmin: DOS vulnerabiltiy in table editing
Keywords:
Status: NEW
Alias: CVE-2017-1000014
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1416003 1416004 1416005 1416006
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 10:52 UTC by Adam Mariš
Modified: 2019-09-29 14:04 UTC (History)
11 users (show)

Fixed In Version: phpMyAdmin 4.6.6, phpMyAdmin 4.4.15.10, phpMyAdmin 4.0.10.19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Adam Mariš 2017-01-24 10:52:31 UTC
It was possible to trigger recursive include operation by crafted parameters when editing table data.

Mitigation:

Do not click on deep phpMyAdmin links on third party sites.

Affected versions:

All 4.6.x versions (prior to 4.6.6), 4.4.x versions (prior to 4.4.15.10), and 4.0.x versions (prior to 4.0.10.19) are affected.

Upstream patches:

https://github.com/phpmyadmin/phpmyadmin/commit/3d230b6
https://github.com/phpmyadmin/phpmyadmin/commit/38f9223
https://github.com/phpmyadmin/phpmyadmin/commit/a134a01

External References:

https://www.phpmyadmin.net/security/PMASA-2017-3/

Comment 2 Adam Mariš 2017-01-24 10:58:47 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1416003]
Affects: epel-all [bug 1416004]

Comment 3 Adam Mariš 2017-01-24 10:58:53 UTC
Created phpMyAdmin4 tracking bugs for this issue:

Affects: epel-5 [bug 1416005]


Note You need to log in before you can comment on or make changes to this bug.