Bug 1478359 (CVE-2017-12424) - CVE-2017-12424 shadow-utils: Buffer overflow via newusers tool
Summary: CVE-2017-12424 shadow-utils: Buffer overflow via newusers tool
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2017-12424
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1491933
Blocks: 1478361
TreeView+ depends on / blocked
 
Reported: 2017-08-04 12:27 UTC by Adam Mariš
Modified: 2019-09-29 14:18 UTC (History)
3 users (show)

Fixed In Version: shadow-utils 4.5
Doc Type: If docs needed, set a value
Doc Text:
A buffer overflow flaw leading to heap memory corruption was found in the shadow-utils's newusers utility. A local, authenticated attacker could potentially use this flaw to crash the newusers process by supplying crafted data to it.
Clone Of:
Environment:
Last Closed: 2017-09-15 04:49:30 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-08-04 12:27:05 UTC
In shadow before 4.5, the newusers tool could be made to manipulate
internal data structures in ways unintended by the authors. Malformed
input may lead to crashes (with a buffer overflow or other memory
corruption) or other unspecified behaviors. This crosses a privilege
boundary in, for example, certain web-hosting environments in which a
Control Panel allows an unprivileged user account to create
subaccounts.

Upstream patch:

https://github.com/shadow-maint/shadow/commit/954e3d2e7113e9ac06632aee3c69b8d818cc8952

Comment 3 Dhiru Kholia 2017-09-15 04:46:50 UTC
Created shadow-utils tracking bugs for this issue:

Affects: fedora-all [bug 1491933]


Note You need to log in before you can comment on or make changes to this bug.