Bug 1490586 (CVE-2017-13019) - CVE-2017-13019 tcpdump: Buffer over-read in print-pgm.c:pgm_print() in PGM parser
Summary: CVE-2017-13019 tcpdump: Buffer over-read in print-pgm.c:pgm_print() in PGM pa...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-13019
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170913,reported=2...
Depends On: 1475364
Blocks: 1490633
TreeView+ depends on / blocked
 
Reported: 2017-09-11 21:53 UTC by Adam Mariš
Modified: 2019-06-08 22:20 UTC (History)
7 users (show)

Fixed In Version: tcpdump 4.9.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-13 03:49:34 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-09-11 21:53:28 UTC
Buffer over-read in print-pgm.c:pgm_print() in PGM parser was found.

This vulnerability can be exploited in two ways. The first is to produce a .pcap file with crafted packet(s) for the protocol(s) concerned and make the target system try to decode the file using tcpdump. The second is to send specially crafted packet(s) to the network segment where the target system is running a tcpdump process that is decoding a live packet capture. In the latter case it depends on the specific network protocol if the crafted packet(s) may be sent from the local segment only or from a remote Internet host.

Comment 1 Adam Mariš 2017-09-11 21:53:32 UTC
Acknowledgments:

Name: the Tcpdump project

Comment 3 Doran Moppert 2017-09-14 04:37:16 UTC
Created tcpdump tracking bugs for this issue:

Affects: fedora-all [bug 1475364]

Comment 4 Doran Moppert 2018-05-16 02:58:20 UTC
This issue was addressed in Red Hat Enterprise Linux 7 via RHEA-2018:0705, which rebased tcpdump to 4.9.2:

https://access.redhat.com/errata/RHEA-2018:0705


Note You need to log in before you can comment on or make changes to this bug.