Bug 1487760 (CVE-2017-13757) - CVE-2017-13757 binutils: heap-based buffer over-read in elf_i386_get_synthetic_symtab in elf32-i386.c and elf_x86_64_get_synthetic_symtab in elf64-x86-64.c
Summary: CVE-2017-13757 binutils: heap-based buffer over-read in elf_i386_get_syntheti...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-13757
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1487762 1487761
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 20:51 UTC by Pedro Sampaio
Modified: 2019-09-29 14:20 UTC (History)
15 users (show)

Fixed In Version: binutils 2.30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:23:53 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2017-09-01 20:51:02 UTC
The Binary File Descriptor (BFD) library (aka libbfd), as distributed
in GNU Binutils 2.29, does not validate the PLT section size, which
allows remote attackers to cause a denial of service (heap-based buffer
over-read and application crash) via a crafted ELF file, related to
elf_i386_get_synthetic_symtab in elf32-i386.c and
elf_x86_64_get_synthetic_symtab in elf64-x86-64.c.

Upstream bug:

https://sourceware.org/bugzilla/show_bug.cgi?id=22018

Upstream patch:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=90efb6422939ca031804266fba669f77c22a274a

Comment 1 Pedro Sampaio 2017-09-01 20:52:25 UTC
Created binutils tracking bugs for this issue:

Affects: fedora-all [bug 1487762]


Created mingw-binutils tracking bugs for this issue:

Affects: epel-all [bug 1487761]


Note You need to log in before you can comment on or make changes to this bug.