Bug 1500377 (CVE-2017-15021) - CVE-2017-15021 binutils: Heap-based buffer over-read in bfd_get_debug_link_info_1
Summary: CVE-2017-15021 binutils: Heap-based buffer over-read in bfd_get_debug_link_in...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-15021
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1499310 1499311
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-10 13:13 UTC by Andrej Nemec
Modified: 2019-09-29 14:24 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:28:41 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-10-10 13:13:45 UTC
bfd_get_debug_link_info_1 in opncls.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.29, allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted ELF file, related to bfd_getl32.

Upstream issue:

https://sourceware.org/bugzilla/show_bug.cgi?id=22197

Upstream patch:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=52b36c51e5bf6d7600fdc6ba115b170b0e78e31d

Comment 1 Andrej Nemec 2017-10-10 13:16:05 UTC
Created binutils tracking bugs for this issue:

Affects: fedora-all [bug 1499311]


Created mingw-binutils tracking bugs for this issue:

Affects: epel-all [bug 1499310]


Note You need to log in before you can comment on or make changes to this bug.