Bug 1500763 (CVE-2017-15190) - CVE-2017-15190 wireshark: RTSP dissector crash
Summary: CVE-2017-15190 wireshark: RTSP dissector crash
Status: NEW
Alias: CVE-2017-15190
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20171010,repor...
Keywords: Security
Depends On: 1500769
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-11 12:28 UTC by Andrej Nemec
Modified: 2018-06-21 09:06 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Andrej Nemec 2017-10-11 12:28:56 UTC
It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.
 
Upstream bug:

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14077

Upstream patch:

https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=e27870eaa6efa1c2dac08aa41a67fe9f0839e6e0

External References:

https://www.wireshark.org/security/wnpa-sec-2017-45.html

Comment 1 Andrej Nemec 2017-10-11 12:33:18 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1500769]


Note You need to log in before you can comment on or make changes to this bug.