Bug 1510919 (CVE-2017-15372) - CVE-2017-15372 sox: Stack-based buffer overflow in the lsx_ms_adpcm_block_expand_i function
Summary: CVE-2017-15372 sox: Stack-based buffer overflow in the lsx_ms_adpcm_block_exp...
Status: CLOSED ERRATA
Alias: CVE-2017-15372
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20171011,reported=2...
Keywords: Security
Depends On: 1510925
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 12:52 UTC by Andrej Nemec
Modified: 2018-06-06 19:03 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-06-06 13:14:35 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-11-08 12:52:09 UTC
There is a stack-based buffer overflow in the lsx_ms_adpcm_block_expand_i function of adpcm.c in Sound eXchange (SoX) 14.4.2. A Crafted input will lead to a denial of service attack during conversion of an audio file.

Product bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1500553

Comment 1 Andrej Nemec 2017-11-08 12:57:07 UTC
Created sox tracking bugs for this issue:

Affects: fedora-all [bug 1510925]

Comment 2 Jiri Kucera 2018-06-06 13:14:35 UTC
Fixed in sox-14.4.2.0-16.fc27 and sox-14.4.2.0-17.fc26.


Note You need to log in before you can comment on or make changes to this bug.