Bug 1516235 (CVE-2017-16645) - CVE-2017-16645 kernel: Out-of-bounds read in drivers/input/misc/ims-pcu.c
Summary: CVE-2017-16645 kernel: Out-of-bounds read in drivers/input/misc/ims-pcu.c
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2017-16645
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1516274
Blocks: 1516236
TreeView+ depends on / blocked
 
Reported: 2017-11-22 10:38 UTC by Andrej Nemec
Modified: 2019-09-29 14:26 UTC (History)
45 users (show)

Fixed In Version: kernel 4.14
Doc Type: If docs needed, set a value
Doc Text:
The ims_pcu_get_cdc_union_desc function in drivers/input/misc/ims-pcu.c in the Linux kernel, through 4.13.11, allows local users to cause a denial of service (ims_pcu_parse_cdc_data out-of-bounds read and system crash) or possibly have unspecified other impact via a crafted USB device.
Clone Of:
Environment:
Last Closed: 2018-02-25 14:18:05 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-11-22 10:38:21 UTC
The ims_pcu_get_cdc_union_desc function in drivers/input/misc/ims-pcu.c in the Linux kernel through 4.13.11 allows local users to cause a denial of service (ims_pcu_parse_cdc_data out-of-bounds read and system crash) or possibly have unspecified other impact via a crafted USB device.

References:

https://groups.google.com/forum/#!msg/syzkaller/q6jjr1OhqO8/WcA99AVFBAAJ

http://seclists.org/oss-sec/2017/q4/392

An upstream patch:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ea04efee7635c9120d015dcdeeeb6988130cb67a

Comment 1 Andrej Nemec 2017-11-22 11:50:40 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1516274]

Comment 4 Vladis Dronov 2018-02-25 14:18:05 UTC
Statement:

This issue does not affect the Linux kernel packages as shipped with Red Hat Enterprise Linux 5, 6, 7, its real-time kernel, Red Hat Enterprise MRG 2, Red Hat Enterprise Linux 7 for ARM 64 and Red Hat Enterprise Linux 7 for Power 9 LE, as a code with the flaw is not present or is not built in the products listed.


Note You need to log in before you can comment on or make changes to this bug.