Bug 1524893 (CVE-2017-17501) - CVE-2017-17501 GraphicsMagick: Heap-based buffer overflow in the WriteOnePNGImage
Summary: CVE-2017-17501 GraphicsMagick: Heap-based buffer overflow in the WriteOnePNGI...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2017-17501
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20171205,reported=2...
Depends On: 1494551 1494552
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-12 09:42 UTC by Andrej Nemec
Modified: 2019-06-08 22:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:33:47 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-12-12 09:42:06 UTC
WriteOnePNGImage in coders/png.c in GraphicsMagick 1.3.26 has a heap-based buffer over-read. A crafted file could cause the application to crash.

Upstream issue:

https://sourceforge.net/p/graphicsmagick/bugs/526/

Upstream patch:

http://hg.code.sf.net/p/graphicsmagick/code/rev/5b8414c0d0c4

Comment 1 Andrej Nemec 2017-12-12 09:45:32 UTC
Created GraphicsMagick tracking bugs for this issue:

Affects: epel-all [bug 1494551]
Affects: fedora-all [bug 1494552]

Comment 2 Product Security DevOps Team 2019-06-08 03:33:47 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.