Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1528421 - (CVE-2017-17529) CVE-2017-17529 abiword: Command injection in af/util/xp/ut_go_file.cpp
CVE-2017-17529 abiword: Command injection in af/util/xp/ut_go_file.cpp
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,reported=20171221,sou...
: Security
Depends On: 1528422
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-21 14:50 EST by Pedro Sampaio
Modified: 2017-12-21 14:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Sampaio 2017-12-21 14:50:08 EST
af/util/xp/ut_go_file.cpp in AbiWord 3.0.2-2 does not validate strings before
launching the program specified by the BROWSER environment variable, which might
allow remote attackers to conduct argument-injection attacks via a crafted URL.

References:

https://sources.debian.org/src/abiword/3.0.2-5/src/af/util/xp/ut_go_file.cpp/#L1717
Comment 1 Pedro Sampaio 2017-12-21 14:50:39 EST
Created abiword tracking bugs for this issue:

Affects: fedora-all [bug 1528422]

Note You need to log in before you can comment on or make changes to this bug.