Bug 1529382 (CVE-2017-17884) - CVE-2017-17884 ImageMagick: memory leak in function WriteOnePNGImage in coders/png.c
Summary: CVE-2017-17884 ImageMagick: memory leak in function WriteOnePNGImage in coder...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-17884
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1529383 1529384
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-27 20:56 UTC by Laura Pardo
Modified: 2019-09-29 14:28 UTC (History)
3 users (show)

Fixed In Version: ImageMagick 7.0.7-16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:35:41 UTC


Attachments (Terms of Use)

Description Laura Pardo 2017-12-27 20:56:55 UTC
A flaw was found in ImageMagick 7.0.7-16 Q16, a memory leak vulnerability in the function WriteOnePNGImage in coders/png.c file, which allows attackers to cause a denial of service via a crafted PNG image file.

[UPSTREAM BUG]
https://github.com/ImageMagick/ImageMagick/issues/902

[UPSTREAM PATCH]
https://github.com/ImageMagick/ImageMagick/commit/4d6accd355119d54429a86a1859b8329f0130f30

Comment 1 Laura Pardo 2017-12-27 20:57:18 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1529383]


Note You need to log in before you can comment on or make changes to this bug.