Bug 1529578 (CVE-2017-17912) - CVE-2017-17912 GraphicsMagick: heap-based buffer over-read in ReadNewsProfile in coders/tiff.c
Summary: CVE-2017-17912 GraphicsMagick: heap-based buffer over-read in ReadNewsProfil...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2017-17912
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1529579 1529580
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-28 19:06 UTC by Laura Pardo
Modified: 2019-09-29 14:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:35:52 UTC


Attachments (Terms of Use)

Description Laura Pardo 2017-12-28 19:06:50 UTC
A vulnerability was found in GraphicsMagick 1.4 snapshot-20171217 Q8, there is a heap-based buffer over-read in ReadNewsProfile in coders/tiff.c, in which LocaleNCompare reads heap data beyond the allocated region.

[UPSTREAM BUG]
https://sourceforge.net/p/graphicsmagick/bugs/533/

[UPSTREAM PATCH]
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/0d871e813a4f

Comment 1 Laura Pardo 2017-12-28 19:07:12 UTC
Created GraphicsMagick tracking bugs for this issue:

Affects: epel-all [bug 1529580]
Affects: fedora-all [bug 1529579]

Comment 2 Product Security DevOps Team 2019-06-08 03:35:52 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.