Bug 1533599 (CVE-2017-18021) - CVE-2017-18021 qtpass: predictable random password generation
Summary: CVE-2017-18021 qtpass: predictable random password generation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: CVE-2017-18021
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1533600
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-11 17:42 UTC by Laura Pardo
Modified: 2019-09-29 14:29 UTC (History)
1 user (show)

Fixed In Version: qtpass 1.2.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-16 14:48:05 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-01-11 17:42:03 UTC
A flaw was found in QtPass before 1.2.1, when using the built-in password generator. All passwords generated with "QtPass"'s built-in password generator are possibly predictable and enumerable. This only applies to the QtPass GUI.

[UPSTREAM BUG]
https://github.com/IJHack/QtPass/issues/338
https://lists.zx2c4.com/pipermail/password-store/2018-January/003165.html

[UPSTREAM PATCH]
https://github.com/IJHack/QtPass/releases/tag/v1.2.1

Comment 1 Laura Pardo 2018-01-11 17:42:23 UTC
Created qtpass tracking bugs for this issue:

Affects: fedora-all [bug 1533600]


Note You need to log in before you can comment on or make changes to this bug.