Bug 1550353 (CVE-2017-18197) - CVE-2017-18197 jgraphx: XML External Entity (XXE) vulnerability in mxGraphViewImageReader.java:convert()
Summary: CVE-2017-18197 jgraphx: XML External Entity (XXE) vulnerability in mxGraphVie...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-18197
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1550355 1550354 1553282 1553284
Blocks: 1550357
TreeView+ depends on / blocked
 
Reported: 2018-03-01 04:30 UTC by Sam Fowler
Modified: 2019-09-29 14:34 UTC (History)
6 users (show)

Fixed In Version: jgraphx 3.7.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:41:55 UTC


Attachments (Terms of Use)

Description Sam Fowler 2018-03-01 04:30:34 UTC
In jgraphx (mxGraph) before 3.7.6, the SAXParserFactory instance in mxGraphViewImageReader.java:convert() is missing flags to prevent XML External Entity (XXE) attacks.

Upstream Issue:

https://github.com/jgraph/mxgraph/issues/124

Upstream Commit:

https://bitbucket.org/jgraph/mxgraph2/commits/7d159ca3259b961cbb1c51b4ea42cb408c624ff1

Comment 1 Sam Fowler 2018-03-01 04:30:59 UTC
Created jgraphx tracking bugs for this issue:

Affects: fedora-all [bug 1550354]
Affects: epel-6 [bug 1550355]


Note You need to log in before you can comment on or make changes to this bug.