Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1418730 - (CVE-2017-2612) CVE-2017-2612 jenkins: Low privilege users were able to override JDK download credentials (SECURITY-392)
CVE-2017-2612 jenkins: Low privilege users were able to override JDK download...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20170201,repor...
: Security
Depends On: 1418736
Blocks: 1395176 1418735
  Show dependency treegraph
 
Reported: 2017-02-02 10:16 EST by Andrej Nemec
Modified: 2018-06-29 18:18 EDT (History)
13 users (show)

See Also:
Fixed In Version: jenkins 2.44, jenkins 2.32.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2017-02-02 10:16:18 EST
The following flaw was found in Jenkins:

Jenkins allows administrators to enter their username and password to the Oracle download site which provides JDKs for download. Users with read access to Jenkins were able to override these credentials, resulting in future builds possibly failing to download a JDK. A permission check has been added.

External References:

https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2017-02-01

Upstream patch:

https://github.com/jenkinsci/jenkins/commit/b0ed9669bc00dbccf1be6896bb527b4cf2e7687d
Comment 1 Andrej Nemec 2017-02-02 10:49:09 EST
Created jenkins tracking bugs for this issue:

Affects: fedora-all [bug 1418736]

Note You need to log in before you can comment on or make changes to this bug.