Bug 1424977 (CVE-2017-2632) - CVE-2017-2632 cfme: tenant administrator can create a group with higher permissions
Summary: CVE-2017-2632 cfme: tenant administrator can create a group with higher permi...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-2632
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20170227,repor...
Depends On: 1418297 1419686
Blocks: 1424978
TreeView+ depends on / blocked
 
Reported: 2017-02-20 08:54 UTC by Martin Prpič
Modified: 2019-06-08 21:49 UTC (History)
15 users (show)

Fixed In Version: cfme 5.7.1.3
Doc Type: If docs needed, set a value
Doc Text:
A logic error in valid_role() in CloudForms role validation could allow a tenant administrator to create groups with a higher privilege level than the tenant administrator should have. This would allow an attacker with tenant administration access to elevate privileges.
Clone Of:
Environment:
Last Closed: 2017-02-27 20:16:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0320 normal SHIPPED_LIVE Moderate: CFME 5.7.1 bug fixes and enhancement update 2017-02-28 00:13:26 UTC

Description Martin Prpič 2017-02-20 08:54:28 UTC
It was found that a tenant administrator could create groups with roles that have higher permissions than those of the tenant administrator.

Comment 1 Martin Prpič 2017-02-20 08:54:37 UTC
Acknowledgments:

Name: Matouš Mojžíš (Red Hat)

Comment 2 errata-xmlrpc 2017-02-27 19:32:19 UTC
This issue has been addressed in the following products:

  CloudForms Management Engine 5.7

Via RHSA-2017:0320 https://rhn.redhat.com/errata/RHSA-2017-0320.html


Note You need to log in before you can comment on or make changes to this bug.