Bug 1486144 (CVE-2017-3735) - CVE-2017-3735 openssl: Malformed X.509 IPAdressFamily could cause OOB read
Summary: CVE-2017-3735 openssl: Malformed X.509 IPAdressFamily could cause OOB read
Status: CLOSED WONTFIX
Alias: CVE-2017-3735
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170828,reported=2...
Keywords: Security
Depends On: 1486145 1486147 1486146 1527732 1534929 1534930 1655666
Blocks: 1534623
TreeView+ depends on / blocked
 
Reported: 2017-08-29 07:31 UTC by Andrej Nemec
Modified: 2019-04-28 09:34 UTC (History)
60 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-29 07:40:00 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3221 None None None 2018-10-30 07:51 UTC

Description Andrej Nemec 2017-08-29 07:31:08 UTC
If an X.509 certificate has a malformed IPAddressFamily extension,
OpenSSL could do a one-byte buffer overread. The most likely result
would be an erroneous display of the certificate in text format.

External References:

https://www.openssl.org/news/secadv/20170828.txt

References:

https://github.com/openssl/openssl/pull/4276

Comment 1 Andrej Nemec 2017-08-29 07:31:54 UTC
Created mingw-openssl tracking bugs for this issue:

Affects: epel-7 [bug 1486145]
Affects: fedora-all [bug 1486147]


Created openssl tracking bugs for this issue:

Affects: fedora-all [bug 1486146]

Comment 3 Takahiro Sasaki 2018-01-09 00:48:09 UTC
CVSS3 Base Score is 5.3 (https://access.redhat.com/security/cve/cve-2017-3735), which means RedHat is failed on PCI compliance (pg. 31 in https://www.pcisecuritystandards.org/documents/ASV_Program_Guide_v3.0.pdf

I believe RedHat don't want to leave the customers failed on PCI compliance.  I'm using the Amazon Linux AMI so it's following RHEL/EPEL 6.  Please address this ASAP.

Comment 5 Huzaifa S. Sidhpurwala 2018-01-17 06:36:47 UTC
Statement:

This flaw only exhibits itself when:
1. OpenSSL is used to display details of a local or a remote certificate.
2. The certificate contains the uncommon RFC 3779 IPAddressFamily extension.

The maximum impact of this flaw is garbled information being displayed, there is no impact on the availability of service using such a certificate. Also this flaw can NOT be used to create specially-crafted certificates. Red Hat Product Security has rated this issue as having Low security impact. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

Comment 6 errata-xmlrpc 2018-10-30 07:50:56 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2018:3221 https://access.redhat.com/errata/RHSA-2018:3221


Note You need to log in before you can comment on or make changes to this bug.