Bug 1449520 (CVE-2017-8365) - CVE-2017-8365 libsndfile: Buffer over-read in the l2les_array function
Summary: CVE-2017-8365 libsndfile: Buffer over-read in the l2les_array function
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-8365
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1449521
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-10 08:27 UTC by Andrej Nemec
Modified: 2019-09-29 14:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-10 08:32:15 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-05-10 08:27:56 UTC
The i2les_array function in pcm.c in libsndfile allows attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file.

References:

https://blogs.gentoo.org/ago/2017/04/29/libsndfile-global-buffer-overflow-in-i2les_array-pcm-c/

Comment 1 Andrej Nemec 2017-05-10 08:28:54 UTC
Created libsndfile tracking bugs for this issue:

Affects: fedora-all [bug 1449521]


Note You need to log in before you can comment on or make changes to this bug.