Bug 1456756 (CVE-2017-9117) - CVE-2017-9117 libtiff: Heap-based buffer over-read in bmp2tiff
Summary: CVE-2017-9117 libtiff: Heap-based buffer over-read in bmp2tiff
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-9117
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20170507,repor...
Depends On: 1456757 1456759 1456758
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-30 10:06 UTC by Adam Mariš
Modified: 2019-06-08 22:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:13:40 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-05-30 10:06:17 UTC
In LibTIFF 4.0.7, the program processes BMP images without verifying that biWidth and biHeight in the bitmap-information header match the actual input, leading to a heap-based buffer over-read in bmp2tiff.

Upstream bug:

http://bugzilla.maptools.org/show_bug.cgi?id=2690

Comment 1 Adam Mariš 2017-05-30 10:06:41 UTC
Created libtiff tracking bugs for this issue:

Affects: fedora-all [bug 1456758]


Created mingw-libtiff tracking bugs for this issue:

Affects: epel-7 [bug 1456757]
Affects: fedora-all [bug 1456759]


Note You need to log in before you can comment on or make changes to this bug.