Bug 1574852 (CVE-2018-10380) - CVE-2018-10380 pam-kwallet: Access to privileged files
Summary: CVE-2018-10380 pam-kwallet: Access to privileged files
Status: NEW
Alias: CVE-2018-10380
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=important,public=20180504,repo...
Keywords: Security
Depends On: 1574853
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 07:46 UTC by Andrej Nemec
Modified: 2019-06-08 22:51 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Andrej Nemec 2018-05-04 07:46:15 UTC
It was found that kwallet-pam was doing file writing and permission changing as root that with correct timing and use of carefully crafted symbolic links could allow a non privileged user to become the owner of any file on the system.

External References:

https://www.kde.org/info/security/advisory-20180503-1.txt

Upstream patches:

https://commits.kde.org/kwallet-pam/2134dec85ce19d6378d03cddfae9e5e464cb24c0
https://commits.kde.org/kwallet-pam/01d4143fda5bddb6dca37b23304dc239a5fb38b5

Comment 1 Andrej Nemec 2018-05-04 07:46:52 UTC
Created pam-kwallet tracking bugs for this issue:

Affects: epel-7 [bug 1574853]

Comment 2 Fedora Update System 2018-05-14 17:53:18 UTC
pam-kwallet-5.12.5-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 3 Fedora Update System 2018-05-14 18:34:52 UTC
pam-kwallet-5.12.5-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.