Bug 1592166 (CVE-2018-10856) - CVE-2018-10856 podman: Containers run as non-root users do not drop capabilities
Summary: CVE-2018-10856 podman: Containers run as non-root users do not drop capabilities
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-10856
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1584429 1592167 1594309
Blocks: 1592169
TreeView+ depends on / blocked
 
Reported: 2018-06-18 00:39 UTC by Sam Fowler
Modified: 2019-09-29 14:42 UTC (History)
6 users (show)

Fixed In Version: podman 0.6.1
Doc Type: If docs needed, set a value
Doc Text:
It has been discovered that podman does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
Clone Of:
Environment:
Last Closed: 2019-06-10 10:29:27 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:2037 0 None None None 2018-06-26 18:40:25 UTC

Description Sam Fowler 2018-06-18 00:39:22 UTC
Podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Comment 1 Sam Fowler 2018-06-18 00:39:46 UTC
Created podman tracking bugs for this issue:

Affects: fedora-all [bug 1592167]

Comment 5 errata-xmlrpc 2018-06-26 18:40:19 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7 Extras

Via RHSA-2018:2037 https://access.redhat.com/errata/RHSA-2018:2037


Note You need to log in before you can comment on or make changes to this bug.