Bug 1579488 (CVE-2018-10999) - CVE-2018-10999 exiv2: heap-based buffer over-read in parseTXTChunk function
Summary: CVE-2018-10999 exiv2: heap-based buffer over-read in parseTXTChunk function
Keywords:
Status: CLOSED DUPLICATE of bug 1578659
Alias: CVE-2018-10999
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1579489 1579486
Blocks: 1579499
TreeView+ depends on / blocked
 
Reported: 2018-05-17 18:33 UTC by Laura Pardo
Modified: 2019-09-29 14:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 20:23:34 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-05-17 18:33:09 UTC
An issue was discovered in Exiv2 0.26. The Exiv2::Internal::PngChunk::parseTXTChunk function has a heap-based buffer over-read.


References:
https://github.com/Exiv2/exiv2/issues/306

Comment 1 Laura Pardo 2018-05-17 18:34:31 UTC
Created exiv2 tracking bugs for this issue:

Affects: fedora-all [bug 1579486]

Comment 3 Pedro Yóssis Silva Barbosa 2018-05-24 20:23:34 UTC

*** This bug has been marked as a duplicate of bug 1578659 ***


Note You need to log in before you can comment on or make changes to this bug.