Bug 1584904 (CVE-2018-11625) - CVE-2018-11625 ImageMagick: heap-based buffer over-read in SetGrayscaleImage in the quantize.c
Summary: CVE-2018-11625 ImageMagick: heap-based buffer over-read in SetGrayscaleImage ...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-11625
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1584905 1584906
Blocks: 1584907
TreeView+ depends on / blocked
 
Reported: 2018-05-31 21:53 UTC by Laura Pardo
Modified: 2021-02-17 00:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-05 15:30:03 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-05-31 21:53:49 UTC
A flaw was found in ImageMagick 7.0.7-37 Q16, SetGrayscaleImage in the quantize.c file allows attackers to cause a heap-based buffer over-read via a crafted file.


References:
https://github.com/ImageMagick/ImageMagick/issues/1156

Patch:
https://github.com/ImageMagick/ImageMagick/commit/5294966898532a6bd54699fbf04edf18902513ac

Comment 1 Laura Pardo 2018-05-31 21:54:39 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1584905]

Comment 4 Scott Gayou 2018-06-05 15:30:10 UTC
Statement:

This issue did not affect the versions of ImageMagick as shipped with Red Hat Enterprise Linux 5, 6, and 7.


Note You need to log in before you can comment on or make changes to this bug.