Bug 1588742 (CVE-2018-11712) - CVE-2018-11712 webkitgtk: Improper TLS certificate verification for WebSocket connections
Summary: CVE-2018-11712 webkitgtk: Improper TLS certificate verification for WebSocket...
Keywords:
Status: NEW
Alias: CVE-2018-11712
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1588743 1588750 1588751 1588752 1588753 1588754 1599969 1599974
Blocks: 1588756
TreeView+ depends on / blocked
 
Reported: 2018-06-07 19:34 UTC by Pedro Sampaio
Modified: 2019-09-29 14:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-08 01:00:20 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2018-06-07 19:34:50 UTC
WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp in the libsoup network backend of WebKit, as used in WebKitGTK+ versions 2.20.0 and 2.20.1, failed to perform TLS certificate verification for WebSocket connections.

Upstream issue:

https://bugs.webkit.org/show_bug.cgi?id=184804

Upstream patch:

https://trac.webkit.org/changeset/230886/webkit

Comment 1 Pedro Sampaio 2018-06-07 19:35:10 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-28 [bug 1588743]

Comment 2 Pedro Sampaio 2018-06-07 19:37:26 UTC
Created mingw-webkitgtk tracking bugs for this issue:

Affects: fedora-all [bug 1588750]


Created mingw-webkitgtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1588754]


Created webkitgtk tracking bugs for this issue:

Affects: epel-all [bug 1588751]
Affects: fedora-all [bug 1588753]


Created webkitgtk4 tracking bugs for this issue:

Affects: fedora-all [bug 1588752]


Note You need to log in before you can comment on or make changes to this bug.