Bug 1671097 (CVE-2018-12022) - CVE-2018-12022 jackson-databind: improper polymorphic deserialization of types from Jodd-db library
Summary: CVE-2018-12022 jackson-databind: improper polymorphic deserialization of type...
Status: NEW
Alias: CVE-2018-12022
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=important,public=20180529,repo...
Keywords: Security
Depends On: 1672879 1672881 1700946 1700977 1700978 1671098 1672880 1700947
Blocks: 1666431
TreeView+ depends on / blocked
 
Reported: 2019-01-30 17:40 UTC by Laura Pardo
Modified: 2019-05-16 08:32 UTC (History)
54 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:0782 None None None 2019-04-17 21:01 UTC
Red Hat Product Errata RHSA-2019:0877 None None None 2019-04-24 18:47 UTC
Red Hat Product Errata RHSA-2019:1106 None None None 2019-05-08 12:04 UTC
Red Hat Product Errata RHSA-2019:1107 None None None 2019-05-08 12:09 UTC
Red Hat Product Errata RHSA-2019:1108 None None None 2019-05-08 12:11 UTC
Red Hat Product Errata RHSA-2019:1140 None None None 2019-05-09 18:15 UTC

Description Laura Pardo 2019-01-30 17:40:31 UTC
FasterXML jackson-databind before versions 2.7.9.4, 2.8.11.2, 2.9.6 fails to block polymorphic deserialization of types from Jodd-db library. This could lead to Remote Code Execution.


Reference:
https://github.com/FasterXML/jackson-databind/issues/2052

Upstream Patch:
https://github.com/FasterXML/jackson-databind/commit/7487cf7eb14be2f65a1eb108e8629c07ef45e0a1

Comment 1 Laura Pardo 2019-01-30 17:40:45 UTC
Created jackson-databind tracking bugs for this issue:

Affects: fedora-all [bug 1671098]

Comment 2 James Hebden 2019-02-14 06:40:36 UTC
OpenDaylight does not include jodd, but does ship impacted versions of jackson
databind. We have covered this in #1671096 - so I will not add additional
affects here, given the library is not used, and the commit fixing this issue
is exactly the same commit as 1671096, where we do ship both a vulnerable
jackson-databind and JODBC support, despite not shipping the impacted classes.

Comment 7 Doran Moppert 2019-02-18 03:42:21 UTC
Statement:

Red Hat Satellite 6 is not affected by this issue, since Candlepin's java runtime environment does not load Jodd classes.

Red Hat Virtualization 4 is not affected by this issue, since it does not load Jodd classes.

Comment 21 errata-xmlrpc 2019-04-17 21:01:13 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.4 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.5 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.6 EUS

Via RHSA-2019:0782 https://access.redhat.com/errata/RHSA-2019:0782

Comment 22 errata-xmlrpc 2019-04-24 18:47:07 UTC
This issue has been addressed in the following products:

  Red Hat Openshift Application Runtimes

Via RHSA-2019:0877 https://access.redhat.com/errata/RHSA-2019:0877

Comment 24 errata-xmlrpc 2019-05-08 12:04:20 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform

Via RHSA-2019:1106 https://access.redhat.com/errata/RHSA-2019:1106

Comment 25 errata-xmlrpc 2019-05-08 12:09:29 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 6

Via RHSA-2019:1107 https://access.redhat.com/errata/RHSA-2019:1107

Comment 26 errata-xmlrpc 2019-05-08 12:11:51 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 7

Via RHSA-2019:1108 https://access.redhat.com/errata/RHSA-2019:1108

Comment 27 errata-xmlrpc 2019-05-09 18:15:04 UTC
This issue has been addressed in the following products:

  Red Hat Single Sign-On 7.3.1 zip

Via RHSA-2019:1140 https://access.redhat.com/errata/RHSA-2019:1140


Note You need to log in before you can comment on or make changes to this bug.