Bug 1597427 (CVE-2018-12983) - CVE-2018-12983 podofo: stack-based buffer over-read in the PdfEncryptMD5Base::ComputeEncryptionKey function
Summary: CVE-2018-12983 podofo: stack-based buffer over-read in the PdfEncryptMD5Base:...
Status: CLOSED UPSTREAM
Alias: CVE-2018-12983
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20180627,reported=2...
Keywords: Security
Depends On: 1597429 1597432 1597433
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-02 22:36 UTC by Laura Pardo
Modified: 2019-06-10 10:31 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-10 10:31:25 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-07-02 22:36:00 UTC
A flaw was found in PoDoFo 0.9.6-rc1. A stack-based buffer over-read in the PdfEncryptMD5Base::ComputeEncryptionKey() function in PdfEncrypt.cpp could be leveraged by remote attackers to cause a denial-of-service via a crafted pdf file.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1595693

Comment 1 Laura Pardo 2018-07-02 22:36:49 UTC
Created mingw-podofo tracking bugs for this issue:

Affects: fedora-all [bug 1597432]


Created podofo tracking bugs for this issue:

Affects: epel-all [bug 1597433]
Affects: fedora-all [bug 1597429]

Comment 2 Product Security DevOps Team 2019-06-10 10:31:25 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.